Friday 1st June 2018

SOHO Pro, Business Pro, Fibre Pro and Talk Surf Connection Blip

We’re investigating an issue with TTB as we’ve observed a drop in their network.

Some customers may have lost their connection and be unable to reconnect currently.

Update: A large majority of connections returned shortly after. For those that have no connection, please leave your modem/router disconnected for 15 minutes.

Update: We have seen no further issues in over 24 hours. A RFO will follow to affected customers once received from TTB.