Thursday 15th September 2016

General Netflix

Netflix appear to have blocked some users accounts as they believe they are using proxies. This is a policy decision by them and not us.

We have no proxies in our network and cannot resolve this despite what the first line support at Netflix claim. All customers are given a static IP address which is assigned to the router directly.

This block can occur when the Netflix account is used via one of the many VPN, proxy and DNS based routing services that allow non-UK content to be viewed but these are not provided by us.

If you are facing such an error, please contact Netflix and confirm this is not an ISP issue. We have emailed the tr@ mailbox as before and await their response but history tells us that this will not be a quick process.

Update: We're on the phone to them again. Proving the error message that we've been provided but apparently, this isn't a Netflix error message!

Update: Tier 3 support at Netflix are "investigating".

Update: A further call to Netflix has assured us that they are investigating but the team in question are not there until later today (West Coast US, which is -8 hours behind UK). They could not provide a ticket number or reference however but state this has been communicated to their teams.

Update: We've called again and spoken to another supervisor with the same script as before, that we need to email them. We explain that we have but it seems no one that answers their phones can do anything useful. We ask all those affected to please email tr[@]netflix.com and state their issue, that you do not use a proxy and your IP. Netflix are giving varying degrees of misinformation out such as "reset connection", "reset router", "contact TV manufacturer" or "contact ISP" yet none of this will make any difference.

Update: Netflix have unblocked the IPs. Hurrah!